How can we improve Microsoft Translator for Edge?

I keep getting a message that says "we detected a higher than normal traffic from your computer...... please type in characters shown to con

10 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    7 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • meg commented  ·   ·  Flag as inappropriate

        Please fix this problem, it is supposed to translate for goodness sake, stop telling me you have detected higher than normal traffic.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Yes, I am fed up with it too. I'll drop Edge completely if you don't fix it very quickly!

      • Graeme Hatton commented  ·   ·  Flag as inappropriate

        Do you actually read the comments? Only I'm having the same problem and it will not accept the characters I've copied. I have tried every means possible. As for the speak the words, I understand a Scandinavian speaker better that your electronic voice!! Back to Google methinks!

      • Anonymous commented  ·   ·  Flag as inappropriate

        I agree with comments below, load of rubbish, get rid of the "we detected a higher than normal traffic from your computer..message

      • keith lawson commented  ·   ·  Flag as inappropriate

        I like edge but the request to confirm my usage of your translator is getting a bit of a pain **********! Going back to chome

      • David commented  ·   ·  Flag as inappropriate

        These messages are getting silly - every page requires verification

      • Anonymous commented  ·   ·  Flag as inappropriate

        I have attempted numerous times to type in the characters (correctly) but the message then tells me that it is incorrect (but fr sure I am doing it correctly. When I attempt audio it speaks in a non English language, please help me.

      Feedback and Knowledge Base