How can we improve Microsoft Translator for Edge?

We’ve detected higher than normal traffic from your computer or network. Please type in the characters you see below to continue translating

"We've detected higher than normal traffic from your computer or network. Please type in the characters you see below to continue translating."

Why do I keep getting this message? Make it go away

44 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Fukayumama shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Gwenda responded  · 

    Hi,

    Thanks for your message on the translator forum and I’m sorry to read this is happening. Please help us understand what is going wrong:

    Which of our translator services are you using?
    Can you please share a screenshot?

    Thanks,
    Gwenda
    Microsoft Translator Team

    34 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        I have suddenly started getting this message all the time yet I have been using it for ages without issue. I read page in German and Dutch using it and if I am going to get this all the time then I will be switching back to Google Chrome which doesn't give me all this hassle.

      • leewolves commented  ·   ·  Flag as inappropriate

        Please remove this. Not necessary and annoying.
        When using translator I don't need to be told the level of traffic is higher than normal. How do you determine what my 'normal' amount f traffic is?
        Will install Google Chrome if this continues.
        Please get it sorted!!!!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Type in the characters????????
        Is this a joke?
        Is it possible to complete?
        No combination of upper or lower case has worked so far.

      • Robert West commented  ·   ·  Flag as inappropriate

        It's impossible to determine if the characters are upper or lower case so it takes 15-20 attempts to get it right. I'm giving up and using Chrome (much as I hate it).

      • David commented  ·   ·  Flag as inappropriate

        Even when you do manage to enter the correct characters, you get either a 'characters did not match' or a brief view of the translated page before another verification screen appears. Even the audio is not working. It certainly is not English!!

      • Darren commented  ·   ·  Flag as inappropriate

        This is SO VERY ANNOYING! I am in Japan and use this a lot, I am on the Dell website now trying to research a computer for a client and this just keeps popping up, and I can't read the characters and keep getting it wrong every time. I been trying for half an hour now and always "The characters didn't match the picture. Please try again"

        So what about the amount of traffic anyway? It is what is is!

      • Anonymous commented  ·   ·  Flag as inappropriate

        This verification page is ssoooooo FREAAAAKING annoying! Turn this garbage off! Keeps popping up over and over again and it doesn't translate after the verification anyways. I am uninstalling the translator till this gets fixed. Very frustrated.

        Translated from Czech or German into English. Edge for Windows 10. Using on Microsoft Surface Pro. Fully patched and up to date. Translation used on Amazon and other reputable sites. Still doesn't work properly. THe verification page keeps popping up again and again after a short period of use.

      • Anonymous commented  ·   ·  Flag as inappropriate

        This verification page is ssoooooo FREAAAAKING annoying! Turn this garbage off! Keeps popping up over and over again and it doesn't translate after the verification anyways. I am uninstalling the translator till this gets fixed. Very frustrated.

      • mw commented  ·   ·  Flag as inappropriate

        is there any fix for this issue ? If not then please advise will switch to Chrome...

      • toya woods commented  ·   ·  Flag as inappropriate

        hold the on fix whatever it is and don't ever again broadcast my failed remarks or comments but I do enjoy reading your outbursts please help me to help each other to getting done without damage or anything in the process please now what is exactly broke or first off how are you guys all doing any way for starters I must add that I think that I love you all and it will get better ok thanks

      • toya woods commented  ·   ·  Flag as inappropriate

        I am well and clear looking into this mad traffic stop my speed is not top I'm guessing but its lighting and thundering guaranteed to satisfy once its fixed to my on demand delight

      • Barry commented  ·   ·  Flag as inappropriate

        I live in France and the translator is really helpful, as my French is not that good yet. However, usually when I am filling in French Forms, after completing half the form, the message always comes with:
        "We've detected higher than normal traffic from your computer or network. Please type in the characters you see below to continue translating."

        I enter the code shown on the picture. After that, which is annoying anyway, I usually find that I have to start the form filling all over again. This is incredibly frustrating!

        Is there a way of preventing this?

        Also in Outlook, is there a way of forcing the translator to just translate the message in the current window rather than open a new window for the translation? There is not enough room for this on my laptop, and it seems unnecessary.

      • Alex commented  ·   ·  Flag as inappropriate

        My Translator has figured out somehow that it should always translate Italian pages to English (although that's not what I want). After some time (sometimes several minutes, sometimes an hour) of normal surfing it always ends up with this info "We've detected higher than normal traffic from your computer or network" and I have no way to turn off automatic translation of all Italian pages.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I am also trying to use MS translator for edge and am getting the same problem, this seems to be typical microsoft who seem to be intent on making their users life as problematic as possible. Also translator team when are going to hear from you on this?

      • Aneudy Mota commented  ·   ·  Flag as inappropriate

        When is this going to be fixed?

        I continue to received the following message:

        "We’ve received an unusual volume of traffic from your IP address and will be unable to translate this webpage at the moment.

        Please wait some time before trying again."

      ← Previous 1

      Feedback and Knowledge Base